Why isn't Screen Sharing working?
Cause
When you, as an agent, try to share your screen with a customer during an interaction but only a black screen appears, this is most likely caused by an outdated agent application configuration that is missing the required browser permissions.
Fix
To enable Screen Sharing, you need to update the Iframe Feature/Permissions Policy for the agent integration.
- In Genesys Cloud, go to Admin → Integrations
- Open TrueEngage_VisitorJourneyAgents
- Go to the Configuration tab
- In the Iframe Feature/Permissions Policy field, check whether the following values are set:
cameramicrophoneclipboard-writedisplay-capture
- Add any missing values
- Save the configuration
Refresh Genesys Cloud after saving — Screen Sharing should now work as expected.